Major Service Disruptions for customers in AWS EU-West

Incident Report for Responsive Status Page

Resolved

The team has applied the fix and resolved the issue. All services on EU Pod1 have been confirmed to be operating normally.
Posted Mar 09, 2026 - 03:00 PDT

Identified

We have identified the cause of the service disruptions on EU Pod1, and the team is working on a fix.
Posted Mar 09, 2026 - 02:15 PDT

Investigating

We are currently investigating an issue impacting service availability on EU Pod1, which has resulted in site downtime for customers.
Posted Mar 09, 2026 - 01:49 PDT
This incident affected: EU Pod1.