All impacted AWS services had fully recovered, and operations returned to normal across the US-EAST-1 region. Our internal workloads and monitoring confirm stable and healthy service performance across all integrated AWS environments.
Posted Oct 20, 2025 - 15:00 PDT
Monitoring
AWS has implemented initial mitigations and is closely monitoring the impacted services in the US-EAST-1 region.
Posted Oct 20, 2025 - 02:22 PDT
Identified
AWS is currently investigating increased error rates and latencies affecting multiple services. AWS is working on a fix.
Posted Oct 20, 2025 - 01:26 PDT
Investigating
We are currently facing an outage in AWS East-1 (North Virginia) region, AWS has reported a service disruption in the region, impacting multiple services. Customers in this region might face degraded performance, increased latency.
Posted Oct 20, 2025 - 00:11 PDT
This incident affected: US Pod2, US Pod9, and US Pod11.